Umstieg von TRNG auf Tomb Editor

  • Hallo zusammen,


    ich habe mich heute neu hier registriert. Im Vorfeld habe ich schon einige Zeit mit TRNG (NG-Center) gebaut.

    Vor kurzem habe ich dann den Tomb Editor entdeckt und benutze nun die Version 1.3.4.


    Ich habe nun nach einiger Suche dieses Forum für meine Fragen zum Tomb Editor entdeckt.


    Bis jetzt bin ich richtig begeistert von dem Script Werkzeug und dem IDE Tool und der Tomb Editor ist trotz

    großer Umgewöhnung ein Traum:love:. Selbst mein schneller PC (i5 Prozessor) kommt mit dem Editor klar. Mit

    TRNG hatte ich ständig Anzeigefehler und zu schnelle Rotationen, weswegen ich TRNG nur auf einem langsameren

    Laptop benutzen konnte.


    Bei meinem ersten eigenen Level, welches ich ursprünglich mit dem NGLE begonnen hatte, habe ich nun die Weiterarbeit

    mit dem Tomb Editor aufgenommen. Ich habe mich soweit schon nach einiger Zeit an Umgewöhnung in den Tomb Editor

    reingefuchst.


    Für meinen Startraum möchte ich am Anfang eine Trigger Group erstellen, um mehrere Teeth Spikes gleichzeitig mit einem

    Trigger auslösen zu können. Um das im Script anpassen zu können habe ich mit dem TombIDE Tool schon mal einen eigenen,

    separaten Projektordner erstellt. Auch habe ich damit begonnen das Script mit dem Script Editor des IDE Tools anzupassen.


    Allerdings habe ich nun ein kleines Problem. Wenn ich meinen Level abspeichere und baue wird seltsamerweise immer eine

    alte Version des Raumes gebaut. Der Raum hat ein großes, tiefes Wasserbecken in der Mitte des Raumes. Das Wasserbecken

    hat eine Umrandung (mit Teeth Spikes darauf) und vier Säulen an den den Ecken der Umrandung des Wasserbeckens. Wenn

    ich nun den Raum baue wird mir das Wasserbecken schwarz texturiert angezeigt wobei die Umrandung und der restliche Raum

    texturiert sind. Und die Leveltexturen sind auch nicht richtig. So wie der Raum gebaut wird, sah er vor einigen Tagen zwar mal aus,

    aber inzwischen habe ich den Raum komplett überarbeitet (Wasser mit: Toggle Opacity 2, Texturenanimationen, double sided und

    transparent) und auch die Texturen hatte ich neu aufgetragen (auch im Wasserbecken). Ich habe auch alle Autosaves gelöscht und

    die Autosavefunktion deaktiviert. In den Einstellungen des Tomb Editors (unter "Tools, Level Settíngs, Game") habe ich auch die

    Verzeichnisse richtig zugwiesen. Über die Launch.exe im erstellten Projektordner lässt sich das Level auf jeden Fall starten.


    Mein Ordneraufbau ist:


    C/Games/Tomb Raider Level Editor: Completed Levels; Software; Textures; Wads


    Completed Levels: Projektordner (in diesem Fall "The Maze"): diesen Projektordner habe ich mit dem IDE Tool erstellt. Auch liegt

    hier die trproj Datei sowie die Ordner Script, Engine, Levels, Sounds.


    Sofware: TRLE; TRLE Tools; Tomb Editor: hier liegt im Ordner Projects die prj2 Datei für den Tomb Editor


    Von daher habe ich folgende Fragen:

    1.) Müssen die Verzeichnisse (unter Tomb Editor: "Tools, Level Settíngs, Game") dem jeweiligen mit dem IDE Tool erstellten

    Projektordner zugewiesen werden oder muss ich die dem normalen TRLE Verzeichnis vom Standard Leveleditor zuweisen?

    2.) Muss meine Projektdatei (prj2 nicht trproj), die ich mit dem Tomb Editor erstellt habe auch in dem Projektordner (The Maze)

    abgelegt werden oder kann ich die separat speichern? (In meinem Fall liegt die Datei im Installationsordner des Tomb Editors; dort

    habe ich einen extra Ordner "Projects" erstellt.)

    3.) Warum baut der Editor meinen Level nicht so wie er aktuell im Editor erstellt und gespeichert ist? Wieso werden meine

    Änderungen nicht übernommen?:?::?::?:

    4.) Werden auch bald Tutorials zum IDE Tool erstellt?

    5.) Warum braucht der Script Editor im IDE Tool eigentlich noch das NG-Center um das Script über "File" und "Build Script" zu bauen?

    Da wird nämlich nur automatisch das NG-Center aufgerufen.

    6.) Warum wird über die eben genannte "Build Script"-Funktion eigentlich keine DAT Datei vom Script erstellt? Wenn nämlich keine

    Fehler vorhanden sind schließt sich das NG-Center automatisch wieder, aber es ist nirgendwo eine DAT Datei vom Script zu finden.


    Danke schon Mal für eure Hilfe und Bemühungen im Voraus:).

    Bei Unklarheiten fragt ruhig genauer nach. Ich hoffe ich habe das Problem verständlich geschildert

  • So, ich versuche mal zu helfen. Ich muss aber ehrlicherweise auch sagen, dass ich das TombIDE Programm nur mal testweise gestartet hatte. Da ich mit meinem "TMB" Projekt noch mit dem NG Center angefangen habe.


    1) Also die Verzeichnisse müssen so sein wie du sie benötigst. Der Spielordner selber muss dann theoretisch auf dem Ordner von der TombIDE verweisen, da das Tool ja wie Jörg mir heute mal per WhatsApp mitteilte einen eigenen "Spielbaren Ordner erstellt".

    Da du ja beim erstellen des Projektes in TombIDE die Option "Store newly created Levels inside the project folder (Default)" sicher nicht verändert hattest. Daher greift TombIDE auf diesen Spielbaren Ordner zu, du aber vermutlich im Projekt in den Einstellungen den alten drinnen hast. Daher vermutlich das Problem mit den "veralteten Daten".

    2) Die "xy.trproj" ist die "Projekt Datei" von TombIDE. Hat daher nichts mit dem TombEditor zu tun.

    3) Du wirst hier vermutlich einfach einen kleinen Konflikt haben wegen den falschen Pfadangaben.

    Im Ordner "Engine" des TombIDE Projektes ist der spielbare Ordner "vermutlich" enthalten.

    4) Ja Tutorials sollten von unserer Seite natürlich auch bald folgen. Die ganze TE Geschichte ist halt natürlich sehr aufwendig, gerade in Sachen Tutorials schreiben. Daher sind wir natürlich auch froh wenn jemand gerne mithilft beim Tutorials schreiben, da aktuell Jörg und ich alleine welche schreiben. Wir haben daher die Tutorials von TombIDE nicht vergessen, sind aber ehrlicherweise einfach noch nicht dazu gekommen.

    5) Da muss ich jetzt leider passen, ich hab die TombIDE leider noch nicht so genau angesehen. Aber ich werde dies demnächst mal in Angriff nehmen. Habe zwar nächste Woche Urlaub, aber leider werde ich da noch keine Zeit dafür haben. Eher die Woche darauf.

    6) Die Script.dat/English.dat werden im "Engine" Ordner des TombIDE Projektes angelegt. Anbei mal ein Bild meines gerade erstellten "Blanco Projektes".

  • Super. Danke schon mal für die schnelle Antwort :).


    1) Die Einstellung "Store newly created Levels inside the project folder (Default)" habe ich nicht geändert.


    3) Also irgendwie ist das ziemlich verhext: Ich habe die Verzeichnisse in den Settings folgendermaßen angelegt:


    Folder in which all runtime game components reside:

    "C/Games/Tomb Raider Level Editor/Completed Levels/The Maze


    Target folder and filename for level file:

    ..../Completed Levels/The Maze/Levels/The Maze.tr4


    Target executable that ist started with the 'Build and Play' button:

    .../Completed Levels/The Maze/The Maze.exe


    Allerdings ist es komisch, dass die Pfade manchmal rot markiert sind oder sich verstellen obwohl ich sie mit apply

    festgesetzt habe. Wenn ich sie dann neu zuweise ist die rote Markierung wieder weg. Gerade bei folgender Einstellung

    "Folder in which all runtime game components reside:" bin ich nicht sicher ob der Pfad richtig ist.


    In welchem Ordner sind den normal die runtime files drin?


    4) Macht euch kein Stress vieles habe ich mit dem IDE Tool schon herausgefunden. Mir ging es nur darum zu erfahren,

    ob dazu Tutorials in Planung sind.


    6) Super jetzt habe ich die DAT Datei auch entdeckt. :thumbup:


    Viele Grüße.

  • So nun bin ich schon mal ein bisschen schlauer. Beim IDE Tool hab ich übersehen, dass links ein Fenster zum

    Importieren von Leveln ist. Da konnte ich schon mal meine prj2 Datei importieren. Der Levelname wurde

    automatisch benannt (The Maze). Allerdings taucht mein Level nun in tomb4.exe nicht in der Levelliste auf (da

    steht nur 3x Missing). Und wenn ich direkt vom Tomb Editor auf "build and play" klicke, stürzt er beim Laden

    der tomb4.exe immer ab (das Bauen des Levels klappt aber). Nur wenn ich direkt im Projetkordner die tomb4.exe

    anwähle/doppelklicke startet die tomb4.exe ohne Absturz.


    Und wenn ich die importierte Datei im IDE Tool links anwähle/doppelklicke wird das Projekt im Tomb Editor zwar

    geöffnet, aber meine Teeth Spikes sehen aus wie Ghost Blocks und die Texturen sind total komisch blau.


    Danke schon mal für den Hinweis mit dem Levelimport, dass habe ich total übersehen.:):thumbup:

    Ich habe mich schon die ganze Zeit gefragt, ob ich mit dem IDE Tool die prj2 Datei zuordnen/importieren kann/muss.

  • So ich hab noch etwas herausgefunden. Wenn man seine prj2 Datei in IDE importiert, wird

    die prj2 Datei in einem extra Ordner unter "Levels" abgelegt. Ich musste jetzt nur beim

    öffnen der prj2 Datei über das IDE Tool das Wadfile und das TGA-file neu im Editor zu-

    weisen, da er die Dateien nicht gefunden hat. Somit ist die prj2 Datei nun an 2 Orten gespeichert.


    Jetzt ist zumindest schon mal das Absturzproblem nach "build and play" im Tomb Editor behoben.

    Allerdings steht beim Starten der tomb4.exe nun wieder Missing in der Levelauswahl.


    Ich habe den Projektordner jetzt noch einmal neu erstellt und das Script noch mal neu gemacht.

    Irgendwas habe ich da wohl noch übersehen. Allderdings steht der Levelname in beiden Scriptfiles.


    Für heute mach ich erst Mal Schluss. Morgen bin ich wieder online.

  • Wenn im Spiel immer „missing“ steht heißt das eigentlich, dass die TR4 Datei nicht so wie im Script angegeben heißt. Überprüfe dies Mal.

    Den beim TE ist es ja so, dass man den Pfad zur TR4 natürlich direkt fest angeben kann, oder eben so benennen kann, wie die Projekt Datei heißt.

    Ich hab auch öfters missing drinnen wenn ich mal TR4 Dateien lösche oder für den Spielwaren Ordner wenn noch nicht alle Levels mitgeliefert werden sollen.

  • Im data Ordner habe ich tatsächlich eine doppelte tr4 Datei entdeckt. Einmal "The Maze.tr4" und The_Maze.tr4".

    Die habe ich nun gelöscht und in den Settings des Editors die Datei ohne Unterstrich zugewiesen.


    Nun stürzt der Editor nach "build and play", aber wieder ab. Wenn ich die tomb4.exe per Doppelklick öffne

    startet tomb4.exe ohne Absturz und das Level erscheint in der Auswahlliste. Beim Anwählen stürzt das

    Level jedoch ab. Der Ladebildschirm wird zwar angezeigt und der Balken wird komplett geladen, aber dann

    stürzt es ab.


    Muss die tomb4.exe im Engine Ordner eigentlich auch umbenannt werden? Da ich ja die normale mit dem IDE Tool

    umbenannt habe.


    Was ist eigentlich mit der Layer1 Zeile im Script? Brauche ich die überhaupt? Wozu ist die nochmal gut?

    Bei mir hat sie diese Werte: 160,160,192,7. Die habe ich erst mal nur kopiert um sie später nach Bedarf zu ändern.



    Viele Grüße.

  • Ich melde mich nächste Woche noch mal. Am 01.07.20 habe ich noch meine mündliche Abschluss-

    prüfung. Daher schaffe ich es erst mal nicht mit dem Tomb Editor weiterzumachen, da ich mich

    noch auf die Prüfung vorbereiten muss.


    Ist es eigentlich problematisch für den Editor, wenn das Wad File, das TGA File, das exe File und das

    tr4 file den gleichen Name haben ("The Maze").


    Bis nächste Woche :).

  • Viel Glück für die Prüfung.


    Normal sollte es egal sein wie die Daten heißen. Aber versuche mal ohne "Leerzeichen" die Dateinamen zu nehmen, also "TheMaze". Evtl. verursacht dies ja auch das Problem?

    Ansonsten darfst du mir auch gerne mal die Daten hochladen, dann schaue ich mal nach wo das Problem liegt. Den so Ferndiagnosen sind natürlich immer etwas schwer.

  • Meinst du die Projektdateien The Maze.prj2 und The Maze.proj? Brauchst du zum

    Prüfen noch mehr Dateien?


    Mir ist gerade noch aufgefallen, dass die proj Datei tomb.proj heißt und nicht The Maze.proj.

    Ich habe die noch einmal manuell umbenannt und mit dem IDE Tool verknüpft. Ab heute

    ist die proj Datei also doppelt in meinem Ordner. Abstürzen tut das Level leider immer noch.


    Viele Grüße!


    The Maze.zip

  • Versuch mal die tr4 ohne Leerzeichen, also"themaze.tr4" und trag das auch so im Script ein, wäre nun meine Idee;)

  • Das TGA- und das Wadfile bekomme ich leider nicht hochgeladen, da die zu groß sind. Ich hab sie zwar mit 7Zip komprimiert, aber ich bekomme sie nur auf 0,98 MB und 1,03 MB komprimiert. Selbst das Wadfile bekomme ich mit 0,98 MB nicht hochgeladen, obwohl von der Seite hier bis zu 1MB erlaubt sind:(. Ich hoffe Mal die Dateien reichen so zur Prüfung. Im Ordner hatte ich die trproj, die prj2 und die Scripts hochgeladen.

  • Inzwischen konnte ich das Problem mit Hilfe von illyaine lösen. Ich habe noch einmal alles neu gebaut und folgendes geändert:


    Am Anfang habe ich erst den Level im Tomb Editor gebaut, dann habe ich das Projekt in TombIDE erstellt und dann die prj2 Datei

    importiert.


    1) Jetzt habe ich erst das Projekt bzw. den Projektordner in IDE erstellt und dann den Level erst in TombIDE erstellt (über "Create New

    Level" anstatt "Import Level"). Danach habe ich dann den Level im Tomb Editor gebaut.


    2) Auch habe ich nun den extra Ordner für die prj2 Datei ("Projects" im Tomb Editor Ordner) weggelassen. Ich benutze jetzt nur

    noch den Ordner "Levels" im erstellten Projektordner (IDE). Hier wird ohnehin beim Erstellen des Projektordners eine prj2

    Datei angelegt.

    3) So funktioniert es besser, da das Scrpt so schon automatisch angepasst wird ("LoadCam" auf 0, 0, 0, 0, 0, 0, 0 und der Levelname

    wird in beiden Scriptdateien gleich übernommen und auch die entsptechende Levelsektion wird schon erstellt).


    Vermutlich hatte ich irgendwie falsche Werte in der LoadCam Zeile stehen, da ich diese nur aus einem vorhanden Script kopiert hatte.

    Eigentlich wollte ich die dann im Nachhinein anpassen. Ein Grund für die Abstürze könnte auch gewesen sein, dass ich erst keine "Default

    Sprites" in der Waddatei eingefügt hatte. Nach diesen Veränderungen startet der Level. Mein Hauptverdacht ist jedoch, dass ich zuerst den Projektordner hätte erstellen müssen sowie unter Punkt 2 beschrieben. Dann scheint allerding die Importfunktion in TombIDE ("Import

    Level") nicht zu funktionieren. Vielleicht lag es aber auch daran, dass ich 2 prj2 Dateien an 2 verschiedenen Speicherorten gespeichert hatte.



    Zum Schluss noch mal 2 andere Fragen:


    1b) Funktionieren "TriggerGroups", "Organizer" und "ItemGroups" genauso wie bei TRNG? Ich hab da noch ein Tutorial für diese Themen, das aber

    für TRNG geschrieben wurde. Kann ich das dafür benutzen oder funktioniert das mit dem Tomb Editor alles wieder ganz anders?


    2b) Wie kann ich es ändern, dass der Tomb Editor richtig angezeigt wird? Auf meinem Laptop mit kleinerem Bildschirm wird der untere Teil nicht

    komplett angezeigt. Alt + Enter funktioniert hier nicht wie beim NGLE oder TRLE. Und auch im Vollbildmodus fehlt der untere Teil.



  • So letzte Woche habe ich es nun hinbekommen alle Teeth Spikes mit einem Trigger via ItemGroup zu triggern.

    So weit habe ich die ItemGroup schon mal verstanden.


    Nun spinnt aber irgendwie die Timer Einstellung bei den Triggern. Ich wollte 2 Tür seperat timen, aber entweder gehen

    sie gar nicht auf oder sie gehen auf aber nicht wieder zu. Das komische ist das es mit dem NGLE klappt, aber mit

    dem Tomb Editor nicht. Ich hab jetzt immer niedrige Werte genommen (1 - 10).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!