Posts by Chester11

    Alles klar. Hier ist noch Mal eine andere Tür bei der es genauso nicht geht. Ich weiß leider nicht mehr wo ich die runtergeladen habe.

    Bei TRforge und in der Levelbase habe ich sie nicht mehr gefunden.


    Zumindest funktioniert seltsamerweise bei den großen Metallgittertüren (Gates) die Close-Animation (sowohl "rusty gates" als auch "Fully 3D

    Gates"). Die großen Gates gehen nach oben auf und nach unten zu, aber die kleinen Gates schwenken seitlich auf und dann nicht

    wieder zu!


    Viel Erholung für deinen Urlaub. :)

    Files

    Mit dem Speichern habe ich das auch so gemacht, aber das hat nicht geklappt.


    Ich habe jetzt das Problem gelöst in dem ich andere Türen verwendet bzw. runtergeladen habe.

    Komischerweise spinnen jedoch auch alle anderen Metallgittertüren, die ich im Internet gefunden habe.

    Kaum hatte ich eine normale Tür ohne Gitter genommen, hat alles geklappt. Die Tür ließ sich per Antitrigger

    ganz normal schließen und sogar mit der Timerfunktion geht die neue Tür jetzt auch auf einmal ganz normal

    wieder zu.


    Also scheint das Problem mit der "nicht funktionierenden" Timerfunktion wohl nur speziell die Metallgittertüren

    zu betreffen, z. B.:


    https://www.trsearch.org/item/2703

    Oha... Ich merke gerade dass ich mit dem Wad Merger noch lückenhafte Kenntnissse habe.

    Wad Files kann ich problemlos erstellen und auch die Funktion "Switch Manager" kann ich gut.

    Aber wie ich nun Animationen zuweise weiß ich dummerweise nicht. Wahrscheinlich geht das

    mit dem "Animation Editor" richtig? Aber warum ist immer standardmäßig "No Animation" eingestellt,

    wenn die Türen trotzdem aufgehen und die normalen doors aus tr4 auch bei dieser Einstellung

    eine Schließen-Animation machen? Auch ist es komisch, dass wenn ich auf "File" und "Save Wad" die

    Änderung speichere, diese aber nicht übernommen wird.


    Oder bin ich da gerade total falsch?


    Auch bin ich mir noch nicht sicher wie die Ordner in den Einstellungen von Wad Merger zugeordnet

    werden sollen. Bis jetzt habe ich nur den "Orginal Wad Folder" zugeordnet. Kennt ihr Tutorials für

    Wad Merger, z. B. Animationen zuweisen?


    Und dann ist auch die Frage woher ich die Sounds für die Tür im Link herbekomme? Bis jetzt habe ich

    noch nichts passendes gefunden. Und beim Download waren glaube ich keine Sounds für die Tür dabei.

    Richtig die Tür ist es. Das probier ich morgen gleich Mal aus. Danke für die schnelle Hilfe.


    Und ich denk schon die ganze Zeit entweder bin ich zu blöd, um das richtig zu triggern oder der Editor spinnt. Dabei ist die Tür das Problem. ^^

    Was mir gerade noch einfällt:


    Zu 1: Die Geometriewerkzeuge bieten natürlich auch noch mehr Möglichkeiten, z. B. "Portal Digger", um schnell ein Portal zu setzen; "Terrain" um unebenen Boden in einem markierten Bereich zu machen; oder eben "Drag", um Floor und Ceiling zu erhöhen oder runter zuziehen; "Smooth", "Pencil" und "Brush" etc.


    5. Einen spielbaren Ordner kann man gleich ganz leicht mit Tomb IDE erstellen, was viel leichter und schneller funktioniert als bei TRNG

    6. Das Sciptwerkzeug ist in Tomb IDE direkt integriert und bietet tolle Features, z. B. wird der Syntax des Scriptbefehls im kleine, schmalen Fenster unten angezeigt; Befehle werden meist auch direkt vorgeschlagen

    7. Das Script wird bei richtiger vorheriger Einstellung in Tomb IDE gleich vorgefertigt und muss nicht erst extra angepasst, um z. B., das Level zum Testen spielabar zu machen. Der Grundaufabau ist somit schon vorgegeben und man muss, z. B. nur noch den Startbildschirm festlegen und alles was dann im weiteren Verlauf des Levelbaus hinzukommt im Script ergänzen.

    => Dafür muss man bloß zuerst den spielbaren Ordner erstellen. Dann über "create new" in Tomb IDE => "Project Master" eine neue prj2 Datei erstellen, die im spielbaren Ordner unter "Levels" angelegt wird. Dann kann per Doppelklick gleich die zunächst leere prj2 Datei im Tomb Editor öffnen und mit dem Bauen beginnen. => So wird die LoadCam Zeile auf "Null" gesetzt, die Wad-Datei ist auch gleich automatisch im Script verlinkt und der Level Name wird auch gleich mit übernommen (in beiden Datein Script.txt und Englisch.txt).

    Von einem Raum sollen 2 Türen abgehen. Die Türen sollen sich nach dem Öffnen wieder schließen, sodass nur ein Weg begehbar ist, weil es 2 seperate Wege zum Ziel geben soll.


    Erst wollte ich zum Öffnen der Türen bloß einen Trigger oder Pad nehmen, habe mich nun aber für einen Push Button entschieden. Da die Timerparameter, aber nicht funktionieren, wollte ich nun die Türen mit einem Antitrigger oder Antipad hinter den jeweiligen Türen diese schließen. Also man drückt den Push Button, geht durch die Tür und diese schließt hinter einem.

    => Von daher sind hier die Trigger nicht gestapelt. (Einer ist vor und der andere hinter Tür).


    Die Türen und der Push Button kommen nicht aus den offiziellen Tomb Raider Spielen. Die habe habe ich von Fanseiten (hauptsächlich "trsearch" und "Laras Levelbase") runtergeladen und sind von anderen Levelbauern gebaut und veröffentlicht worden. Der Push Button ist "small". Ich kann gerne Screenshots machen, aber eigentlich sind die Trigger total einfach.


    Im NGLE habe ich, z. B. einfach testweise einen Raum gebaut, diesen mit einer Wall begrenzt. Dann habe ich eine Tür eingesetzt und einfach einen Pad vor der Tür und einen Antipad hinter der Tür gesetzt. Da hat alles super geklappt.

    => Der einzige Unterschied ist, dass ich im Projektlevel im Tomb Editor einen Raum mit 2 Ausgängen gebaut habe. Wobei die Gânge hinter den Türen natürlich wieder seperate Räume im Tomb Editor sind und ich zum Öffnen small Push Buttons genommen habe.

    Unbenannt 1.pdf Unbenannt 2.pdf

    Ich versteh's gerade überhaupt nicht. Jetzt wollte ich, um die beiden Türen zu

    schließen hinter den Türen je einen Antitrigger oder Antipadtrigger setzen, aber sie schließen auch so nicht.


    Zum Öffnen benutze ich nun je einen Push Button, was auch klappt. Im NGLE funktioniert es zumindest mit dem Schließen

    der Türen. Nur der Tomb Editor spackt anscheinend rum, was das Schließen der Türen betrifft.

    Braucht man einen Account, um bei tombraiderforums wegen dem evtl. Bug bei den Entwicklern nachzufragen?

    Ich bin da nämlich nicht registriert und würde mich auch nur ungern deswegen dort anmelden.


    Oder gibt es sonst noch andere Möglichkeiten die Entwlicker Mal danach zu fragen?


    LG :)

    1. Sehr vielfältige, nützliche Geometriewerkzeuge, sodass man schneller bekannte Formen wie, z. B. Pyramiden, Rampen, Kugeln und Quartier Pipes mit ein paar Klicks erstellen kann.


    2. Sehr nützliche Texturenwerkzeuge, wie, z. B. Group Texturing


    3. Bei TriggerGroups müssen die Werte für das Script bzw. der Trigger nicht extra exportiert werden (wie noch bei NGLE), sondern die Werte werden beim Tomb Editor im Trigger-Menü direkt rechts unten angezeigt. Sodass man sie ohne Triggerexport direkt ins Script übertragen kann.


    4. Ghost Blocks.

    So letzte Woche habe ich es nun hinbekommen alle Teeth Spikes mit einem Trigger via ItemGroup zu triggern.

    So weit habe ich die ItemGroup schon mal verstanden.


    Nun spinnt aber irgendwie die Timer Einstellung bei den Triggern. Ich wollte 2 Tür seperat timen, aber entweder gehen

    sie gar nicht auf oder sie gehen auf aber nicht wieder zu. Das komische ist das es mit dem NGLE klappt, aber mit

    dem Tomb Editor nicht. Ich hab jetzt immer niedrige Werte genommen (1 - 10).

    Inzwischen konnte ich das Problem mit Hilfe von illyaine lösen. Ich habe noch einmal alles neu gebaut und folgendes geändert:


    Am Anfang habe ich erst den Level im Tomb Editor gebaut, dann habe ich das Projekt in TombIDE erstellt und dann die prj2 Datei

    importiert.


    1) Jetzt habe ich erst das Projekt bzw. den Projektordner in IDE erstellt und dann den Level erst in TombIDE erstellt (über "Create New

    Level" anstatt "Import Level"). Danach habe ich dann den Level im Tomb Editor gebaut.


    2) Auch habe ich nun den extra Ordner für die prj2 Datei ("Projects" im Tomb Editor Ordner) weggelassen. Ich benutze jetzt nur

    noch den Ordner "Levels" im erstellten Projektordner (IDE). Hier wird ohnehin beim Erstellen des Projektordners eine prj2

    Datei angelegt.

    3) So funktioniert es besser, da das Scrpt so schon automatisch angepasst wird ("LoadCam" auf 0, 0, 0, 0, 0, 0, 0 und der Levelname

    wird in beiden Scriptdateien gleich übernommen und auch die entsptechende Levelsektion wird schon erstellt).


    Vermutlich hatte ich irgendwie falsche Werte in der LoadCam Zeile stehen, da ich diese nur aus einem vorhanden Script kopiert hatte.

    Eigentlich wollte ich die dann im Nachhinein anpassen. Ein Grund für die Abstürze könnte auch gewesen sein, dass ich erst keine "Default

    Sprites" in der Waddatei eingefügt hatte. Nach diesen Veränderungen startet der Level. Mein Hauptverdacht ist jedoch, dass ich zuerst den Projektordner hätte erstellen müssen sowie unter Punkt 2 beschrieben. Dann scheint allerding die Importfunktion in TombIDE ("Import

    Level") nicht zu funktionieren. Vielleicht lag es aber auch daran, dass ich 2 prj2 Dateien an 2 verschiedenen Speicherorten gespeichert hatte.



    Zum Schluss noch mal 2 andere Fragen:


    1b) Funktionieren "TriggerGroups", "Organizer" und "ItemGroups" genauso wie bei TRNG? Ich hab da noch ein Tutorial für diese Themen, das aber

    für TRNG geschrieben wurde. Kann ich das dafür benutzen oder funktioniert das mit dem Tomb Editor alles wieder ganz anders?


    2b) Wie kann ich es ändern, dass der Tomb Editor richtig angezeigt wird? Auf meinem Laptop mit kleinerem Bildschirm wird der untere Teil nicht

    komplett angezeigt. Alt + Enter funktioniert hier nicht wie beim NGLE oder TRLE. Und auch im Vollbildmodus fehlt der untere Teil.



    Das TGA- und das Wadfile bekomme ich leider nicht hochgeladen, da die zu groß sind. Ich hab sie zwar mit 7Zip komprimiert, aber ich bekomme sie nur auf 0,98 MB und 1,03 MB komprimiert. Selbst das Wadfile bekomme ich mit 0,98 MB nicht hochgeladen, obwohl von der Seite hier bis zu 1MB erlaubt sind:(. Ich hoffe Mal die Dateien reichen so zur Prüfung. Im Ordner hatte ich die trproj, die prj2 und die Scripts hochgeladen.

    Wie gut kennst du dich mit Triggern denn schon aus? Weißt du wie man ein Hebelrätsel aus TR1 "Der Palast des Midas"

    erstellt? Falls nicht gibt es auf https://www.trforge.net/tutorials/ 2 sehr gute Trigger Tutorials. Dort wird das Schalterrätsel aus TR1

    "Der Palast des Midas" auch erklärt. Auch werden hier Codebits und Triggetypen sehr gut erklärt.


    Die Basis für dein Hebelrästsel wäre ja ein Triggerrätsel wie aus TR1 "Der Palast des Midas". Wie es funktioniert, dass man

    bei einer falschen Kombination Gegner auslöst weiß ich allerdings nicht auf Anhieb.

    Meinst du die Projektdateien The Maze.prj2 und The Maze.proj? Brauchst du zum

    Prüfen noch mehr Dateien?


    Mir ist gerade noch aufgefallen, dass die proj Datei tomb.proj heißt und nicht The Maze.proj.

    Ich habe die noch einmal manuell umbenannt und mit dem IDE Tool verknüpft. Ab heute

    ist die proj Datei also doppelt in meinem Ordner. Abstürzen tut das Level leider immer noch.


    Viele Grüße!


    The Maze.zip

    Ich melde mich nächste Woche noch mal. Am 01.07.20 habe ich noch meine mündliche Abschluss-

    prüfung. Daher schaffe ich es erst mal nicht mit dem Tomb Editor weiterzumachen, da ich mich

    noch auf die Prüfung vorbereiten muss.


    Ist es eigentlich problematisch für den Editor, wenn das Wad File, das TGA File, das exe File und das

    tr4 file den gleichen Name haben ("The Maze").


    Bis nächste Woche :).

    Im data Ordner habe ich tatsächlich eine doppelte tr4 Datei entdeckt. Einmal "The Maze.tr4" und The_Maze.tr4".

    Die habe ich nun gelöscht und in den Settings des Editors die Datei ohne Unterstrich zugewiesen.


    Nun stürzt der Editor nach "build and play", aber wieder ab. Wenn ich die tomb4.exe per Doppelklick öffne

    startet tomb4.exe ohne Absturz und das Level erscheint in der Auswahlliste. Beim Anwählen stürzt das

    Level jedoch ab. Der Ladebildschirm wird zwar angezeigt und der Balken wird komplett geladen, aber dann

    stürzt es ab.


    Muss die tomb4.exe im Engine Ordner eigentlich auch umbenannt werden? Da ich ja die normale mit dem IDE Tool

    umbenannt habe.


    Was ist eigentlich mit der Layer1 Zeile im Script? Brauche ich die überhaupt? Wozu ist die nochmal gut?

    Bei mir hat sie diese Werte: 160,160,192,7. Die habe ich erst mal nur kopiert um sie später nach Bedarf zu ändern.



    Viele Grüße.

    So ich hab noch etwas herausgefunden. Wenn man seine prj2 Datei in IDE importiert, wird

    die prj2 Datei in einem extra Ordner unter "Levels" abgelegt. Ich musste jetzt nur beim

    öffnen der prj2 Datei über das IDE Tool das Wadfile und das TGA-file neu im Editor zu-

    weisen, da er die Dateien nicht gefunden hat. Somit ist die prj2 Datei nun an 2 Orten gespeichert.


    Jetzt ist zumindest schon mal das Absturzproblem nach "build and play" im Tomb Editor behoben.

    Allerdings steht beim Starten der tomb4.exe nun wieder Missing in der Levelauswahl.


    Ich habe den Projektordner jetzt noch einmal neu erstellt und das Script noch mal neu gemacht.

    Irgendwas habe ich da wohl noch übersehen. Allderdings steht der Levelname in beiden Scriptfiles.


    Für heute mach ich erst Mal Schluss. Morgen bin ich wieder online.